Import and Visualize Confluence Data in Power View

Ready to get started?

Download for a free trial:

Download Now

Learn more:

Confluence ODBC Driver

The Confluence ODBC Driver is a powerful tool that allows you to connect with live data from Confluence, directly from any applications that support ODBC connectivity.

Access Confluence data like you would a database - read, write, and update Confluence Attachments, Comments, Groups, Users, etc. through a standard ODBC Driver interface.



Create data visualizations based on Confluence data in Excel.

You can use the built-in ODBC support in Excel to rapidly create Power View reports featuring Confluence data. This article shows how to use the Data Connection Wizard, accessible from the Data ribbon, to import Confluence data into a Power View report.

Connect to Confluence as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Obtaining an API Token

An API token is necessary for account authentication. To generate one, login to your Atlassian account and navigate to API tokens > Create API token. The generated token will be displayed.

Connect Using a Confluence Cloud Account

To connect to a Cloud account, provide the following (Note: Password has been deprecated for connecting to a Cloud Account and is now used only to connect to a Server Instance.):

  • User: The user which will be used to authenticate with the Confluence server.
  • APIToken: The API Token associated with the currently authenticated user.
  • Url: The URL associated with your JIRA endpoint. For example, https://yoursitename.atlassian.net.

Connect Using a Confluence Server Instance

To connect to a Server instance, provide the following:

  • User: The user which will be used to authenticate with the Confluence instance.
  • Password: The password which will be used to authenticate with the Confluence server.
  • Url: The URL associated with your JIRA endpoint. For example, https://yoursitename.atlassian.net.

When you configure the DSN, you may also want to set the Max Rows connection property. This will limit the number of rows returned, which is especially helpful for improving performance when designing reports and visualizations.

Connect with the Data Connection Wizard

Follow the steps below to connect to the DSN from the Data Connection Wizard in Excel.

  1. On the Data tab, click From Other Sources -> From Data Connection Wizard.
  2. In the Data Connection Wizard, select the ODBC DSN option.
  3. Select the ODBC DSN for Confluence from the list.
  4. Select the tables you want to work with.

    If you want to import multiple tables, deselect the "Connect to a specific table" option. After you connect to the data source, you can select multiple tables: After you click Finish to close the Data Connection Wizard, select the "Enable selection of multiple tables" option in the Select Table dialog.

  5. In the Import Data dialog, select the destination for your data. For example, select the Table option and the Existing worksheet option. Then click the cell in your worksheet where results should be output.
  6. Click Insert -> Power View to create a new Power View report.

Create a Table

Tables are the starting point for charts and other representations of your data. To create a table, select a column in the field list. You can also drag and drop table names and column names onto the view.

Create Data Visualizations

On the Design tab, you can change tables into charts and other visualizations.