Analyze Microsoft Project Data with Power Pivot

Ready to get started?

Download for a free trial:

Download Now

Learn more:

MS Project ODBC Driver

The Microsoft Project ODBC Driver is a powerful tool that allows you to connect with live Microsoft Project data, directly from any applications that support ODBC connectivity.

Access Tasks, Issues, Projects, Deliverables, etc. like you would a database - read, write, and update MS Project through a standard ODBC Driver interface.



This article walks you through the process of using the CData ODBC Driver for Microsoft Project from Power Pivot. You will use the Table Import Wizard to load Microsoft Project data. You can visually build the import query or use any SQL supported by the driver.

The ODBC protocol is used by a wide variety of Business Intelligence (BI) and reporting tools to get access to different databases. The CData ODBC Driver for Microsoft Project brings the same power and ease of use to Microsoft Project data. This article uses the driver to import Microsoft Project data into Power Pivot.

Connect to Microsoft Project as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

The User and Password properties, under the Authentication section, must be set to valid Microsoft Project user credentials. In addition, you will need to specify a URL to a valid Microsoft Project server organization root or Microsoft Project services file.

Connect from Power Pivot

Follow the steps below to connect to the DSN in Power Pivot.

  1. In Excel, click the Power Pivot Window icon on the Power Pivot tab to open Power Pivot.
  2. Launch the Table Import Wizard: Click the Get External Data from Other Data Sources button.
  3. Select the OLEDB/ODBC source option.
  4. Click Build to open the Data Link Properties dialog.
  5. In the Provider tab, select the Microsoft OLEDB Provider for ODBC Drivers option.
  6. In the Connection tab, select the Use Data Source Name option and then select the Microsoft Project DSN in the menu.

Select and Filter Tables and Views

Follow the steps below to use the wizard to import Microsoft Project tables. As you use the wizard to select, filter, and sort columns of Microsoft Project tables, Power Pivot generates the query to be executed.

  1. After selecting the DSN in the Table Import Wizard, select the option to select from a list of tables.

  2. Click Preview & Filter to select specific columns, sort data, and visually build filters. To include or exclude columns, select and clear the option next to the column name.

    To filter based on column values, click the down arrow button next to the column name. In the resulting dialog, select or clear the column values you want to filter. Alternatively, click Number Filters or Text Filters and then select a comparison operator. In the resulting dialog, build the filter criteria.

  3. Return to the Select Tables and Views page of the wizard. You can access filters by clicking the Applied Filters link in the Filter Details column.

Import and Filter with SQL

You can also import with an SQL query. The driver supports the standard SQL, allowing Excel to communicate with Microsoft Project APIs.

  1. After selecting the DSN in the Table Import Wizard, select the option to write a query.
  2. In the SQL Statement box, enter the query. Click Validate to check that the syntax of the query is valid. Click Design to preview the results and adjust the query before import.

  3. Finish the wizard to import the data for your chosen query.

Refresh On Demand

Connectivity to Microsoft Project APIs enables real-time analysis. To immediately update your workbook with any changes, click Refresh.