Link Visio Shapes to SingleStore Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

SingleStore ODBC Driver

The SingleStore ODBC Driver is a powerful tool that allows you to connect with live data from SingleStore, directly from any applications that support ODBC connectivity.

Access SingleStore data like you would a database - read, write, and update SingleStore. through a standard ODBC Driver interface.



Automatically update SingleStore data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for SingleStore. The driver surfaces SingleStore data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to SingleStore data.

Connect to SingleStore as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

The following connection properties are required in order to connect to data.

  • Server: The host name or IP of the server hosting the SingleStore database.
  • Port: The port of the server hosting the SingleStore database.
  • Database (Optional): The default database to connect to when connecting to the SingleStore Server. If this is not set, tables from all databases will be returned.

Connect Using Standard Authentication

To authenticate using standard authentication, set the following:

  • User: The user which will be used to authenticate with the SingleStore server.
  • Password: The password which will be used to authenticate with the SingleStore server.

Connect Using Integrated Security

As an alternative to providing the standard username and password, you can set IntegratedSecurity to True to authenticate trusted users to the server via Windows Authentication.

Connect Using SSL Authentication

You can leverage SSL authentication to connect to SingleStore data via a secure session. Configure the following connection properties to connect to data:

  • SSLClientCert: Set this to the name of the certificate store for the client certificate. Used in the case of 2-way SSL, where truststore and keystore are kept on both the client and server machines.
  • SSLClientCertPassword: If a client certificate store is password-protected, set this value to the store's password.
  • SSLClientCertSubject: The subject of the TLS/SSL client certificate. Used to locate the certificate in the store.
  • SSLClientCertType: The certificate type of the client store.
  • SSLServerCert: The certificate to be accepted from the server.

Connect Using SSH Authentication

Using SSH, you can securely login to a remote machine. To access SingleStore data via SSH, configure the following connection properties:

  • SSHClientCert: Set this to the name of the certificate store for the client certificate.
  • SSHClientCertPassword: If a client certificate store is password-protected, set this value to the store's password.
  • SSHClientCertSubject: The subject of the TLS/SSL client certificate. Used to locate the certificate in the store.
  • SSHClientCertType: The certificate type of the client store.
  • SSHPassword: The password that you use to authenticate with the SSH server.
  • SSHPort: The port used for SSH operations.
  • SSHServer: The SSH authentication server you are trying to authenticate against.
  • SSHServerFingerPrint: The SSH Server fingerprint used for verification of the host you are connecting to.
  • SSHUser: Set this to the username that you use to authenticate with the SSH server.

Connect SingleStore Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for SingleStore, select the table you want to import, and finish the wizard. This article uses Orders as an example.

Link SingleStore Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link SingleStore entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Orders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other SingleStore entities onto the drawing page and add association lines back to the main topic, Orders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Orders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external SingleStore data.