Link Visio Shapes to SQL Server Data

Ready to get started?

Download for a free trial:

Download Now

Learn more:

SQL Server ODBC Driver

Connect to Microsoft SQL Server-compatible databases from any applications that support ODBC connectivity.

The ODBC Driver offers Direct Mode access to SQL Server through standard Java Database Connectivity, providing extensive compatibility with current and legacy MS SQL versions. Supports secure SQL connectivity and authentication via SSL, Kerberos, Integrated Security, etc.



Automatically update SQL Server data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for SQL Server. The driver surfaces SQL Server data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to SQL Server data.

Connect to SQL Server as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

Connecting to Microsoft SQL Server

Connect to Microsoft SQL Server using the following properties:

  • Server: The name of the server running SQL Server.
  • User: The username provided for authentication with SQL Server.
  • Password: The password associated with the authenticating user.
  • Database: The name of the SQL Server database.

Connecting to Azure SQL Server and Azure Data Warehouse

You can authenticate to Azure SQL Server or Azure Data Warehouse by setting the following connection properties:

  • Server: The server running Azure. You can find this by logging into the Azure portal and navigating to "SQL databases" (or "SQL data warehouses") -> "Select your database" -> "Overview" -> "Server name."
  • User: The name of the user authenticating to Azure.
  • Password: The password associated with the authenticating user.
  • Database: The name of the database, as seen in the Azure portal on the SQL databases (or SQL warehouses) page.

Connect SQL Server Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for SQL Server, select the table you want to import, and finish the wizard. This article uses Orders as an example.

Link SQL Server Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link SQL Server entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Orders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other SQL Server entities onto the drawing page and add association lines back to the main topic, Orders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Orders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external SQL Server data.