Ready to get started?

Learn more about the CData ODBC Driver for Teradata or download a free trial:

Download Now

Link Visio Shapes to Teradata Data

Automatically update Teradata data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Teradata. The driver surfaces Teradata data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Teradata data.

Connect to Teradata as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

To connect to Teradata, provide authentication information and specify the database server name.

  • User: Set this to the username of a Teradata user.
  • Password: Set this to the password of the Teradata user.
  • DataSource: Specify the Teradata server name, DBC Name, or TDPID.
  • Port: Specify the port the server is running on.
  • Database: Specify the database name. If not specified, the default database is used.

Connect Teradata Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Teradata, select the table you want to import, and finish the wizard. This article uses NorthwindProducts as an example.

Link Teradata Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Teradata entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter NorthwindProducts as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Teradata entities onto the drawing page and add association lines back to the main topic, NorthwindProducts. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other NorthwindProducts entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Teradata data.