Ready to get started?

Learn more about the CData JDBC Driver for USPS or download a free trial:

Download Now

Connect to USPS in SpagoBI

Create reports featuring live USPS data in SpagoBI Studio. Host USPS reports on SpagoBI Server.

The CData JDBC Driver for USPS enables you to connect to live USPS data from business intelligence and data mining tools that support the JDBC standard. This article shows how to integrate USPS data into a report in SpagoBI Studio and host it on SpagoBI Server.

Deploy the JDBC Driver in SpagoBI Server

Follow the steps to create a JDBC data source for USPS in SpagoBI Server.

  1. Copy the driver JAR into %CATALINA_BASE%/lib. These files are located in the lib subfolder of the installation directory.
  2. Add a USPS driver resource to the context. The following resource definition can be added to the GlobalNamingResources element in server.xml: <Resource name="jdbc/usps" auth="Container" type="javax.sql.DataSource" driverclassname="cdata.jdbc.usps.USPSDriver" factory="org.apache.tomcat.jdbc.pool.DataSourceFactory" maxactive="20" maxidle="10" maxwait="-1"/>

  3. Add the following resource link to give access to Web applications. For this article, add the following line to META-INF\context.xml for SpagoBI. <ResourceLink global="jdbc/usps" name="jdbc/usps" type="javax.sql.DataSource"/>
  4. Restart the server.

After adding the driver to the resources for the SpagoBI server, add the data source: In SpagoBI, click Resources -> Data Source -> Add and enter the following information:

  • Label: Enter a unique identifier for the driver.
  • Description: Enter a description for the driver.
  • Dialect: Select Default Dialect.
  • Read Only: Select the read-only option. This option determines whether the data source is the default database to save datasets created by the end user.
  • Type: Select JDBC.
  • URL: Enter the JDBC URL using the required connection string properties:

    To authenticate with USPS, set the following connection properties.

    • PostageProvider: The postage provider to use to process requests. Available options are ENDICIA and STAMPS. If unspecified, this property will default to ENDICIA.
    • UseSandbox: This controls whether live or test requests are sent to the production or sandbox servers. If set to true, the Password, AccountNumber, and StampsUserId properties are ignored.
    • StampsUserId: This value is used for logging into authentication to the Stamps servers. This value is not applicable for Endicia and is optional if UseSandbox is true.
    • Password: This value is used for logging into Endicia and Stamps servers. If the postage provider is Endicia, this will be the pass phrase associated with your postage account. It is optional if UseSandbox is true.
    • AccountNumber: The shipper's account number. It is optional if UseSandbox is true.
    • PrintLabelLocation: This property is required to use the GenerateLabels or GenerateReturnLabels stored procedures. This should be set to the folder location where generated labels should be stored.

    The Cache Database

    Many of the useful task available from USPS require a lot of data. To ensure this data is easy to input and recall later, utilize a cache database to make requests. Set the cache connection properties in order to use the cache:

    • CacheLocation: The path to the cache location, for which a connection will be configured with the default cache provider. For example, C:\users\username\documents\uspscache

    As an alternative to CacheLocation, set the combination of CacheConnection and CacheProvider to configure a cache connection using a provider separate from the default.

    Built-in Connection String Designer

    For assistance in constructing the JDBC URL, use the connection string designer built into the USPS JDBC Driver. Either double-click the JAR file or execute the jar file from the command-line.

    java -jar cdata.jdbc.usps.jar

    Fill in the connection properties and copy the connection string to the clipboard.

    A typical JDBC URL is below:

    jdbc:usps:PostageProvider=ENDICIA; RequestId=12345; Password='abcdefghijklmnopqr'; AccountNumber='12A3B4C'
  • Driver: Enter the class name for the driver: cdata.jdbc.usps.USPSDriver

Create Reports in SpagoBI Studio

Follow the steps below to populate reports based on USPS data in SpagoBI Studio. You will create a dataset that populates a chart with the results of an SQL query. In the next section, you will host this report on SpagoBI Server.

First, you will need to connect to USPS data from a report in SpagoBI Studio:

  1. In SpagoBI Studio, click File -> New -> Project and select Report Project in the Business Intelligence and Reporting Tools folder.
  2. Click File -> New -> Report and select Blank Report.
  3. In the Data Explorer view, right-click Data Sources and click New Data Source.
  4. Select JDBC Data Source and enter a name for the data source.
  5. Click Manage Drivers and click Add to add the driver JAR, cdata.jdbc.usps.jar. The driver JAR is located in the lib subfolder of the installation directory.
  6. In the Driver Class menu, select the driver class, cdata.jdbc.usps.USPSDriver.
  7. In the Database URL box, enter the JDBC URL. A typical JDBC URL is below: jdbc:usps:PostageProvider=ENDICIA; RequestId=12345; Password='abcdefghijklmnopqr'; AccountNumber='12A3B4C' See the "Getting Started" chapter of the driver help for a guide to obtaining the required connection properties.

After you have connected to USPS data, create a dataset that contains the results of an SQL query:

  1. Right-click the DataSet folder and click New Data Set. Select the JDBC data source for USPS and enter a name for the dataset.
  2. Build the SQL query. In this example, this query will be used to add a chart to the dashboard. For example: SELECT FirstName, Phone FROM Senders WHERE SenderID = '25'

You can use the dataset to populate report objects. Follow the steps below to create a chart.

  1. In the Palette view, drag a chart onto the canvas.
  2. In the Select Chart Type tab, select a bar chart.
  3. In the Select Data tab, click the Use Data From option and select the USPS data set from the menu.
  4. Drag FirstName from the table to the series for the x-axis.
  5. Drag Phone from the table to the series for the y-axis.

Host USPS Reports on SpagoBI Server

Follow the steps below to host documents based on live USPS data on SpagoBI Server. You will use the report you created in the previous section as a template. To enable report users to access the live data, create placeholder parameters to be replaced by the USPS JDBC data source on the server:

  1. If you have not already done so, open the Report Design perspective in SpagoBI Studio.
  2. In the Data Explorer view, right-click the Report Parameters folder and click New Parameter. Add the url parameter and assign an empty value to it. This parameter is a placeholder for the JDBC data source on the SpagoBI Server.
  3. Right-click the USPS data source and click Edit.
  4. In the Property Binding node, set the JDBC Driver URL binding property to the url parameter: Click the box for the property. In the Category section, select Report Parameters. Select All in the Subcategory section and double-click the parameter.

    You can also enter the following in the JavaScript syntax:

    params["url"].value

Next, create a new document for the report on SpagoBI Server.

  1. In SpagoBI Server, click Documents Development -> Create Document -> Generic Document. The Document Details page is displayed.
  2. To create the document, enter the following:
    • Label: Enter a unique identifier for the document.
    • Name: Enter a user-friendly name for the document.
    • Type: Select Report from the menu.
    • Engine: Select BIRT Report Engine.
    • Data Source: Select the USPS Data Source you created in Create a JDBC Data Source for USPS in SpagoBI Server.
  3. In the Show Document Templates section, select the folder where you want the document to be stored.
  4. In the Template section, click Choose File. Navigate to the folder containing your report project. Select the .rptdesign file.

    Note: You can find the path to the project in the project properties.

  5. Click the Save button.

When you run the report on the server, the placeholder url parameter is replaced with the JDBC URL defined on the server.