Ready to get started?

Learn more about the CData ODBC Driver for UPS or download a free trial:

Download Now

Link Visio Shapes to UPS Data

Automatically update UPS data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for UPS. The driver surfaces UPS data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to UPS data.

Connect to UPS as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

The driver uses five pieces of information in order to authenticate its actions with the UPS service.

  • Server: This controls the URL where the requests should be sent. Common testing options for this are: https://wwwcie.ups.com/ups.app/xml and https://wwwcie.ups.com/webservices
  • AccessKey: This is an identifier that is required to connect to a UPS Server. This value will be provided to you by UPS after registration.
  • UserId: This value is used for logging into UPS. This value is the one you chose to login with when registering for service with UPS.
  • Password: This value is used for logging into UPS. This value is the one you chose to login with when registering for service with UPS.
  • AccountNumber: This is a valid 6-digit or 10-digit UPS account number.
  • PrintLabelLocation: This property is required if one intends to use the GenerateLabels or GenerateReturnLabels stored procedures. This should be set to the folder location where generated labels should be stored.

Connect UPS Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for UPS, select the table you want to import, and finish the wizard. This article uses Senders as an example.

Link UPS Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link UPS entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Senders as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other UPS entities onto the drawing page and add association lines back to the main topic, Senders. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Senders entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external UPS data.