Ready to get started?

Learn more about the CData ODBC Driver for Sage 200 or download a free trial:

Download Now

Link Visio Shapes to Sage 200 Data

Automatically update Sage 200 data with the changes you make to Visio master shapes.

Automate the process of entering data into Visio diagrams and keeping your diagrams up to date with the CData ODBC Driver for Sage 200. The driver surfaces Sage 200 data as an ODBC data source that can be accessed by applications with built-in ODBC support like Microsoft Office. This article shows how to create a simple diagram to start brainstorming about Visio projects linked to Sage 200 data.

Connect to Sage 200 as an ODBC Data Source

If you have not already, first specify connection properties in an ODBC DSN (data source name). This is the last step of the driver installation. You can use the Microsoft ODBC Data Source Administrator to create and configure ODBC DSNs.

  • Schema: Determines which Sage 200 edition you are connecting to. Specify either StandardUK or ProfessionalUK.
  • Subscription Key: Provides access to the APIs that are used to establish a connection. You will first need to log into the Sage 200 API website and subscribe to the API edition that matches your account. You can do so here: https://developer.columbus.sage.com/docs/services/api/uk. Afterwards, the subscription key may be found in your profile after logging into Sage 200.

Connect Sage 200 Data to Diagrams

Follow the steps below to use the Data Selector Wizard to import data into your diagram.

  1. Open Visio and click File -> New. Open the Brainstorming template.
  2. On the Data tab, click Link Data to Shapes.
  3. Select the ODBC option and select ODBC DSN.
  4. Select the DSN for Sage 200, select the table you want to import, and finish the wizard. This article uses Banks as an example.

Link Sage 200 Entities to Shapes

Follow the steps below to create a simple diagram that shows how to create shapes from your data, one of the ways to link Sage 200 entities to shapes:

  1. Click Brainstorming Shapes and drag a main topic onto the drawing page. Enter Banks as the text of the main topic.
  2. Click Topic.
  3. Select a row in the External Data window and drag it onto the drawing page.
  4. Right-click the Topic shape and click Data -> Edit Data Graphic.
  5. Click New Item.
  6. In the Data Field menu, select a column. In the Displayed As menu, select how to display them.
  7. Drag a few other Sage 200 entities onto the drawing page and add association lines back to the main topic, Banks. New topics have the same configuration: Numeric columns displayed in data bars stand out in contrast to other Banks entities.

You can refresh your diagram from the Data tab, synchronizing your shapes with the external Sage 200 data.